All Shared Platforms: AWS Connector Validation failures [IM-12562]

Incident Report for Qualys, Inc.

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 01, 2026 - 15:56 PDT

Update

Qualys Cloud Platform Operations is investigating an issue causing Connector Validation failures in AWS Connector processing. Users may experience issues when endpoints are unreachable from AWS. Based on current observations, AWS connectors will enter an ERROR state if any of the affected region are selected. Also, due to the same issue, AWS connectors are in a queued state on the US Platform 1

If me-south-1 (Bahrain) remains enabled in your multi-region connectors, the connector will enter an Error state and stop processing ALL regions, including healthy ones. This means your visibility into security posture will be completely lost across all AWS regions until it is resolved.

Impacted regions:
AWS Middle East (Bahrain) – me-south-1
As a workaround, customers/users can temporarily unselect this region until AWS services are fully restored.

Immediate Action Required, to restore connector functionality for your other regions:
1. Navigate to TotalCloud → Connectors → [Your AWS Connector]
2. Click Edit Connector
3. Under Regions, uncheck me-south-1 (Bahrain)
4. Click Save
5. Connector will resume scanning other regions within 5-10 minutes

Alternative (API):
bash# Remove me-south-1 from connector regions

curl -X PATCH https://api.totalcloud.io/v1/connectors/{connector-id} \ -H "Authorization: Bearer YOUR_TOKEN" \ -d '{"regions": ["us-east-1", "us-west-2", "eu-west-1"]}' # exclude me-south-1

AWS service status can be tracked here: https://health.aws.amazon.com/health/status

Further updates will be shared as they become available.
The incident ticket for reference is IM-12562.
Posted Apr 01, 2026 - 03:13 PDT

Investigating

Qualys Cloud Platform Operations is investigating an issue causing Connector Validation Runscope failures in AWS Connector processing. Users may experience issues where endpoints are not reachable from AWS. Further updates will be shared as they become available.
Posted Mar 31, 2026 - 23:55 PDT
This incident affects: KSA Platform 1 (Connector Centralization), US Platform 5 (Connector Centralization), AE Platform 1 (Connector Centralization), AU Platform 1 (Connector Centralization), CA Platform 1 (Connector Centralization), UK Platform 1 (Connector Centralization), EU Platform 2 (Connector Centralization), IN Platform 1 (Connector Centralization), EU Platform 1 (Connector Centralization), US Platform 3 (Connector Centralization), US Platform 4 (Connector Centralization), EU Platform 3 (Connector Centralization), US Platform 1 (Connector Centralization), and US Platform 2 (Connector Centralization).